DummyNamespaceTypeDefinition using CciSharp

Topics: ccisharp
Mar 28, 2011 at 6:52 PM

I've been trying out CciSharp with my own mutator. If I run the application directly, and call TypeHelper.BaseClass(definition) on a TypeDefinition instance it returns the expected value. Both the mutator and the assembly being mutated reference the same assembly that defines the expected base class. However, if I run the application as part of the build process then the call returns an instance of Microsoft.Cci.DummyNamespaceTypeDefinition. Any idea what's causing this?

Thanks, Kevin

Mar 29, 2011 at 2:12 PM

Ah, I see why it fails when run during the build process.  When run as a standalone application the executable being processed is in the bin directory, i.e. ...\Demo\bin\Release.  And this also includes the assemblies referenced by the executable.  But when I run CciSharp during the build process, using the targets provided, the executable is still in the obj directory, i.e. ...\Demo\obj\Release, and this doesn't contain the referenced assemblies.